搜索
简帛阁>技术文章>使用Composer安装Yii(win7)

使用Composer安装Yii(win7)

参考:

1、https://getcomposer.org/doc/00-intro.md#installation-windows

2、http://blog.segmentfault.com/luxixing/1190000000492450


补充:

GIT上yii中文安装及手册

手册:https://github.com/yiisoft/yii2/tree/master/docs/guide-zh-CN

目录结构介绍:https://github.com/yiisoft/yii2/blob/master/docs/guide-zh-CN/start-workflow.md

安装:https://github.com/yiisoft/yii2/blob/master/docs/guide-zh-CN/start-installation.md


安装步骤:

1、手动安装Composer

我安装到E:/server目录下

E:\server>php -r "readfile('https://getcomposer.org/installer');" | php
Close your current terminal. Test usage with a new terminal:

<span>C:\Users\aa>composer -V<br style="color:rgb(34,34,34); font-family:sans-serif; font-size:16px; line-height:24px">Composer version 28c65b5425f7f8722c260e3787b74c1ea6b37e3b 2014-06-22 18:24:28
安装成功后会在E:\server目录下生成文件composer.phar

2、用Composer安装初始化yii项目

E:\server>php composer.phar create-project --prefer-dist --stability=dev yiisoft
/yii2-app-basic E:/code/php/yii/basic

Yii框架安装目录:E:\Code\PHP\yii\basic


3、测试安装是否成功

http://localhost/yii/basic/web/index.php




参考:1、https://getcomposerorg/doc/00intromdinstallationwindows2、http://blogsegmentfaultcom/luxixing/11
目前yii2的扩展还不是很多,截止到今天,在官网一共有33个,不过这些插件中不乏有优秀的扩展插件,我尝试了几个,发现了一系列好用的Yii2插件,作者是来自印度的krajee团队,他们写的插件都很好用。
最近在学习PHP,着手找一个能快速上手的框架来学习。一开始看兄弟连视频时候讲师推荐ThinkPHP。于是我选择了ThinkPHP来尝试,这个框架的上手难度系数不大,能快速开发一款应用。适合小型的企业应
这回要说的是,如何给Yii2项目添加外部资源(externalassets,以FontAwesome为例子。Yii2开始使用composer来做项目的依赖管理,这货是类似于NodeJS里面npm的
1.windows下安装composer1)下载composer-Setup.exe时,官网下载地址:https://getcomposer.org/download/,如果官网下载不了,可以到这下载
1下載composer2composer插件或組件3有三處修改acomposerrequire的插件在vender下b同時vender下的composer文件修改ccomposerjson的修改
跟具官方文档说:LaravelutilizesComposertomanageitsdependenciesSo,beforeusingLaravel,youwillneedtomakesureyou
Linux/Mac环境sudowgetO/usr/local/bin/composerhttps://dllaravelchinaorg/composerpharsudochmoda+x/usr/lo
aliyundysms安装composerrequiresaviorlv/yii2dysms:devmaster或者添加下列代码在composerjson文件中并执行composerupdate操作
问题1:Yourrequirementscouldnotberesolvedtoaninstallablesetofpackages则表明未安装fxp/composerassetplugin;解决方法